Back to overview
Downtime

Incident Summary

Apr 13, 2026 at 5:30pm UTC
Affected services
api.synsbasen.dk/v1

Resolved
Apr 13, 2026 at 5:52pm UTC

We've identified and terminated the blocking session and improved our maintenance safeguards to prevent queries from waiting indefinitely on locks.

Created
Apr 13, 2026 at 5:30pm UTC

We experienced a database incident where a long-lived session held a lock on the vehicles table. This blocked a schema migration and caused a buildup of waiting connections from the application.

The session was not automatically terminated because it was not automatically classified as "idle in transaction", so our existing timeout settings did not apply.